CI 4 System Requirements

Share this Article

To Install CodeIgniter 4, we need a PHP version, few PHP extensions and a database driver.

PHP Version

System PHP version should be 7.2 or greater than that.

How to Check PHP version?

There several ways to check what PHP version you are using. The simplest is via CLI command or by making a php file for information.

By Using Terminal

Open terminal and type this command to check PHP version –

$ php --version

You will get your current active PHP version.

By Creating PHP File

Back to your localhost directory. Create a file with any name say info.php.

Open file and write this code into it.

<?php

phpinfo();

Start your server.

Opon browser and type URL like http://localhost/info.php

You should get your current active PHP version.

Required PHP Extensions

Additionally, we need few PHP extensions while installing CodeIgniter 4.

You need to make sure, these following extensions should be enabled.

  • intl extension
  • mbstring extension
  • php-json extension
  • php-mysqlnd extension
  • php-xml extension
  • curl extension

Database Driver Required

A database is required for most web application programming. Currently supported databases are:

  • MySQL (5.1+) via the MySQLi driver
  • PostgreSQL via the Postgre driver
  • SQLite3 via the SQLite3 driver
  • MSSQL via the SQLSRV driver (version 2005 and above only)

Was this post helpful?

Learn Web Development Courses Risk Free @ $5 only.
Web Development Courses @ $5